domingo, 26 de agosto de 2018

Windows no puede finalizar la configuración del sistema

Tal y como comenté recientemente, instalé una máquina virtual con Windows 10 a la que le conseguí hacer un sysprep después de varios problemas al intentar lanzarlo. El caso es que ahora me he encontrado con otro problema. Al reiniciar la máquina para probar la instalación, a mitad de camino, me da otro error:

Windows no puede finalizar la configuración del sistema. Para intentar reanudarla, reinicie el equipo
Windows no puede finalizar la configuración del sistema. Para intentar reanudarla, reinicie el equipo
Aunque voy a enumerar las distintas opciones que he encontrado, ya hago un aviso a navegantes de que sólo he podido averiguar qué es lo que ha hecho que salga este error volviendo a instalar la máquina virtual.

Las posibles soluciones que he encontrado son:

  1. Modificar el registro: si bien en pei.com indican que se modifique la clave del registro setup en Computer\HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\ChildCompletion no me ha funcionado. Para poder abrir el regedit.exe se accede a una consola pulsando Shift+F10 (puede que toque hacer otras combinaciones).
  2. Con una consola, ejecutar tracerpt c:\Windows\Panther\setup.etl -o c:\carpetaAux\setupLogfile.csv -of CSV. Esto permitirá poder abrir el fichero de salida con el notepad (ejecutándolo también desde la consola). Si se le añade el parámetro -of csv nos lo convierte a este formato. Si tuviese algunas herramientas en la misma máquina podría tirar de ellas directamente (como csvviewer de Nirsoft)
tracerpt c:\Windows\Panther\setup.etl -o c:\carpetaAux\setupLogfile.csv
tracerpt c:\Windows\Panther\setup.etl -o c:\carpetaAux\setupLogfile.csv
Lo malo es que son tantos datos que puede ser muy difícil encontrar el problema. 
  1. En troubleshooter.xyz también hay unas cuantas acciones que se pueden hacer. 
  2. En HowISolve proponen abrir desde la ventana del mismo error una consola y, o bien desde c:\Windows\System32\oobe ejecutar msoobe.exe y crear un usuario o abrir una consola mmc y activar alguno de los administradores que se encuentran en el sistema. En mi caso, no he tenido éxito. Corrijo: mientras escribía estas líneas sin ver resultados se ha producido un cambio, posiblemente al ejecutar la primera opción (ya había tirado previamente a por la segunda). Sin embargo, después de muchas horas, no me ha funcionado.

Ninguna de estas opciones me ha funcionado. Por lo que he decidido seguir el consejo del último post de este enlace:

I create a [...] technician VM just before sysprepping [...], run Windows Update and update installed software like browsers and Office, then remove all installers and run Disk Clean-up to remove temp files, sysprep again [...] to replace my old one.

Although Windows Update works in Audit Mode, build and feature upgrades do not work. When I want to upgrade my image I sysprep it once with /generalize, /oobe and /reboot switches, create a dummy local admin account in OOBE, sign in to desktop to upgrade for instance with latest Insider build, when done run sysprep with /audit and /reboot switches to boot back to Audit Mode, remove the dummy user and its profile folder, remove all installers and run Disk Clean-up to remove temp files, sysprep again[...] to replace my old one.

Por lo tanto, ¿qué hice?:
  1. Hice una instalación nueva. 
  2. Actualización completa.
  3. Limpieza de Appx desde powershell
  4. Dism-Clean desde powershell: dism /online /Cleanup-Image /StartComponentCleanup /ResetBase
  5. Instalación de software: 
    1. Navegadores
    2. Notepad ampliado: El "plusplus", sublime... Uno de estos
  6. Un editor gráfico: photoshop, gimp...
  7. Compresor  / Desompresor: Zip, 7zip, Rar
Seguro que me dejo algún programa y algún paso intermedio, pero lo más importante de todo: por cada una de estas hice una copia de seguridad para después lanzar:

sysprep /audit /reboot

Al reiniciar, sólo tuve que eliminar el usuario de la instalación y su perfil tal y como recomendaban en el texto parafraseado. Una vez eliminados: 

sysprep /generalize /oobe /shutdown.

Lo más importante de todo: como se puede ver no he incluido el antivirus. Y es porque antes de instalarlo me hice una copia de seguridad. Si repetía este proceso con el antivirus me volvía a salir el error descrito arriba. Por lo tanto, y de momento, me tocará hacer la instalación de esta herramienta una vez instalada la imagen. El día entero de instalación de parches y pequeños programas me lo ahorro. 

Siento mucho no haber podido ayudar a arreglar el error directamente sin tener que reinstalar. 

1 comentario:

  1. Hola Agux, hay unos errores similares que los resolví, desactivando el "inicio rápido". saludos!

    ResponderEliminar